Using ApSIC Xbench 3.0


ApSIC Xbench allows you to organize and search your bilingual reference terminology. ApSIC Xbench also features several Quality Assurance (QA) checks to boost the quality of your translations. Search features ApSIC Xbench allows you to perform powerful searches on the following bilingual formats: Tab-delimited text files (*.txt, *.tsv, *.utx) XLIFF files, including memoQ XLIFF, Memsource XLIFF, Idiom XLIFF, Translation Workspace XLIFF, XTM XLIFF, and other flavors of XLIFF (*. »

Installing and Uninstalling

Installing ApSIC Xbench ApSIC Xbench 3.0 is available in 32-bit and 64-bit editions. The 32-bit edition can be installed on 32-bit and 64-bit Windows machines. The 64- bit edition can only be installed on 64-bit machines. ApSIC Xbench is supported on Windows XP, Windows Vista, Windows 7, Windows 8, and Windows 10. It is also supported on Windows 2003, Windows 2008, Windows 2012 and Windows 2016. To install ApSIC Xbench, please do the following: »

Launching and Shutting Down

ApSIC Xbench is an application that, once launched, must be explicitly shut down when it is no longer needed. In a normal scenario, you will load your reference project to search for terminology while you are translating and leave it in the background until you finish your translation work. Closing the ApSIC Xbench window does not remove the program from the memory because it is waiting for your next query with the Ctrl+Alt+Insert key sequence. »

Signing Up

ApSIC Xbench licensing system requires that users sign up with their email. When you first start Xbench, a Sign In dialog will appear. If you do not have yet an Xbench account, you need to sign up to create one. Click the Sign Up link in the Sign In window to expand it with the fields for the sign up. Type your email and password twice and click Sign Up for Xbench. »

Defining Search Projects

The first step to use the powerful search features of ApSIC Xbench is to define the reference material for your project. To do so, add the relevant files and directories into your project by choosing Project->Properties or pressing F2. The Project Properties dialog appears as illustrated below. Click the Add button to add files to your project. Select the type of file that you will be adding to the ApSIC Xbench project: »

Searching for Terms

ApSIC Xbench has a very powerful search engine. For example, you can search by source term, target term, or both source and target term. ApSIC Xbench also allows you to search using regular expressions or Microsoft Word wildcards, and combine them using the PowerSearch mode. Likely, most of your searches will be done by source term. However, your need to search for a term will not originate while you are in the interface of ApSIC Xbench, but when you are translating within Word or within some other CAT application such as Trados Studio, memoQ, Wordfast, Déjà Vu, or from a note in your email program such as Microsoft Outlook. »

Regular Expressions and Microsoft Word Wildcards

ApSIC Xbench allows you to perform powerful searches using regular expressions or Microsoft Word wildcards. To activate these search modes, do the following: Choose View->Show Search Options to show the Search Options pane. Expand the Search Mode drop-down and choose Regular Expressions or MS Word Wildcards. You will notice that an icon will appear next to the Source Term and Target Term fields to indicate that you are in the selected mode. »

Special Sets

The following table shows the characters that are matched by the special sets that can be used in regular expressions and Microsoft Word wildcard characters: Special Set Characters matched by the special set [:alpha:] Any of the characters considered as alphabetic by the operating system under the current ANSI code page. [:alphanum:] Any of the characters considered as alphanumeric by the operating system under the current ANSI code page. »

Advanced Features

ApSIC Xbench has some advanced features that you will appreciate when you have special needs. They are described in the following sections. PowerSearch function You can use the Ctrl+P (PowerSearch) key combination to search with more complex criteria. With the PowerSearch function you can search for entries: That contain two or more strings, but not necessarily next to each other. That do not contain a given string. That contain a string or another string. »

Exporting Items

ApSIC Xbench allows you to export the project items in the following formats: TMX files Tab-delimited text files Excel files Word files To export the contents of a project choose Tools->Export Items. The following dialog appears: In this dialog, you can export all items in a project, all items in the current query, only the items displayed in the current query (for example, if you are in overview mode, you only see a few items from each priority level), or all the items of a glossary that is a member of the project. »